Блог

 
 

§265 Управление Mikrotik удаленно при помощи SMS

Управление Mikrotik удаленно при помощи SMS

В двух предыдущих публикациях я уже рассказывал, как можно очень просто подключить 3G-модем к маршрутизаторам Mikrotik и настроить автоматическое переключение основного канала на резервный. Сегодня мы поговорим о том, как можно управлять Mikrotik удаленно при помощи SMS-сообщений. Само собой разумеется, данная инструкция применима для Mikrotik под управлением RouterOS, с установленным 3G-модемом.

Предположим, у нас уже есть настроенная система, по примеру двух предыдущих публикаций. RouterOS имеет неплохой функционал для работы с SMS. Находится он в разделе Tool – SMS. Для того, чтобы Mikrotik имел возможность принимать SMS-сообщения, необходимо активировать соответствующий параметр «Receive Enabled» (Получение включено).

Дополнительно нам потребуется настроить следующие параметры:

  • Port. – как несложно догадаться, это порт USB, на котором находится наш модем;
  • Channel – зависит от установленного модема; для Huawei E173 используется 2-й канал, для остальных модемов информацию необходимо искать, либо подбирать самостоятельно;
  • Secret – специальный пароль, без которого Mikrotik не будет выполнять команды во входящих SMS;
  • Allowed Number – «разрешенный номер», опция необязательна, при её установке, Mikrotik будет выполнять команды только от указанного номера;
  • Keep Max SMS – количество хранимых сообщений; все сообщения хранятся на SIM-карте, поэтому если вы укажите слишком большое количество, а количество сохраненных SMS достигнет предела, Mikrotik не сможет получать новые SMS. Лично я установил 10 – более, чем достаточно.

Есть при настройке пара нюансов, о которых важно помнить! При включенном получении сообщений, поменять параметры нельзя. Поэтому для смены параметров, сначала отключаем получение сообщений, далее меняем параметры, после чего уже можно активировать опцию «Receive Enabled».

Второй нюанс заключается в том, что RouterOS после перезагрузки автоматически отключает приём SMS и после каждой перезагрузки эту опцию необходимо включать вручную.

Чтобы этого не делать вручную, можно создать простенький скрипт с командой

/tool sms set receive-enabled=yes

Управление Mikrotik удаленно при помощи SMS

Лично я назвал его «enable_sms». Запускать скрипт этот требуется только после запуска модема. Как же быть? В коде перед командой включения можно добавить задержку, к примеру, 120 секунд

:delay 120s;

В идеале, нужно добавить также проверку, загрузился ли интерфейс, после чего уже менять настройки. Лично я пошел самым простым путем – в планировщике создал задание с запуском скрипта каждые 10 минут (интервал можно увеличить).

Управление Mikrotik удаленно при помощи SMS

Вот собственно и все настройки, наш Mikrotik уже готов принимать команды.

Отправка SMS-команд на Mikrotik

Синтаксис команды следующий:

:cmd 1234567 script script_name

Здесь 1234567 – пароль, без него Mikrotik не будет выполнять команд; script_name – название скрипта, который необходимо запустить.

Вы можете создать любое количество скриптов, которые будут выполнять необходимые команды. Ниже я приведу несколько команд, которые использую лично я.

Перезагрузка маршрутизатора

Управление Mikrotik удаленно при помощи SMS

Создаем скрипт под названием «reboot», пишем в него код:

/tool sms send usb1 channel=2 "+380931234567" message="Rebooting Mikrotik...";
:delay 5s;
/system reboot

Управление Mikrotik удаленно при помощи SMS

Данный скрипт отправляет на заданный телефон уведомление о том, что Mikrotik выполняет перезагрузку, после небольшой задержки выполняется перезапуск. Задержка необходима для того, чтобы маршрутизатор успел отправить SMS-уведомление.

Управление Mikrotik удаленно при помощи SMS

Для того, чтобы убедиться, что маршрутизатор перезапустился, можно создать новый скрипт, отправляющий SMS, не забудьте про задержку перед отправкой сообщения. Сам скрипт добавить в планировщик, запуск выбрать «startup», т.е. при запуске.

Перезагрузка 3G-интерфейса

Создаем скрипт под названием «reboot3g», пишем в него код:

:log warning ("Rebooting 3G via SMS command");
/tool sms send usb1 channel=2 "+380931234567" message="Rebooting 3G modem...";
/interface ppp-client set ppp-out1 disable=yes;
:delay 1s;
/interface ppp-client set ppp-out1 disable=no;

+380931234567 – как и в предыдущем скрипте меняем на свой номер. ppp-out1 – название нашего 3G-подключения.

Управление Mikrotik удаленно при помощи SMS

Вот собственно и всё, изучаем официальную документацию и создаем необходимые скрипты.



Рекомендуем также
  • Mikrotik Advanced Failover: автоматическое переключение между основным кана ... » В рамках вводной публикации, опубликованной ранее, были изложены основные моменты подключения 3G-модема к маршрутизатору Mikrotik, на примере Huawei E173 и RB952Ui-2nD (hAP). Также мы рассмотрели ...

  • Подключаем 3G-модем к Mikrotik: самый простой вариант резервирования канала ... » Не так давно на одном из небольших филиалов у нас возникли проблемы с интернет-провайдером. Суть проблемы следующая. Есть государственное учреждение, на первом этаже которого есть небольшой филиал. ...

  • Mikrotik выпустил обновление RouterOS 6.37: единый пакет wireless, прекраще ... » Компания Mikrotik официально выпустила обновление RouterOS v.6.37. Настоятельно рекомендуем прочитать список изменений перед обновлением до актуальной версии. Всё дело в том, что компания прекратила ...

  • Настройка Loop Protect в RouterOS на маршрутизаторах Mikrotik » В одной из предыдущих публикаций про обновление RouterOS 6.37 я уже упоминал про добавление функции Loop Protect. Если быть точнее, Loop Protect добавлен в RouterOS начиная с версии 6.37rc25. ...

  • Домашний роутер на Mikrotik. Базовые настройки безопасности в RouterOS. » Итак, вы купили роутер Mikrotik, принесли его домой, распаковали. Что с ним делать дальше? К порту 1 (WAN) следует подключить кабель от интернет-провайдера. Компьютер (ноутбук) подключаем к любому ...

  • Guest Wi-Fi: создание гостевой сети Wi-Fi с ограничением скорости на пример ... » Довольно часто возникают ситуации, когда необходимо предоставить (дома, или же на предприятии) доступ к Интернет через беспроводную сеть сторонним лицам. Сети бывают разными: одни выполняют только ...

  • К вниманию продавцов: новый вид мошенничества на Slando (OLX). Перевод дене ... » Сегодня мы расскажем вам про новый вид мошенничества, который нацелен в первую очередь на ПРОДАВЦОВ, которые продают свои товары на Slando (OLX) и им подобных досках объявлений. Аукционы на Aukro ...


  • Заметка опубликована 25.07.16. Со времени публикации её просмотрели 2725 раз. Если вам понравилась заметка «Управление Mikrotik удаленно при помощи SMS», вы можете поделиться ею со своими друзьями. Всё, что требуется сделать - нажать на одну (или несколько) из кнопок чуть ниже.



     

    Комментарии к заметке

    С момента публикации к заметке оставлено 7 комментариев. Вы можете присоединиться к обсуждению, для этого воспользуйтесь формой ниже. После проверки ваше сообщение появится на сайте. Убедительная просьба: соблюдайте правила.

    #7 | Автор: 820 | 12.09.16 | from Europe
    Сделал прикол в виде обычного смс Reb - микрот перезапускается


    #6 | Автор: DmitryAVET | 10.08.16 | from Ukraine
    Не наблюдал подобных проблем. При поступлении СМС выполняется заданный скрипт - всё. При перезагрузке маршрутизатор не выполняет повторно команды из СМС. Перепроверил.


    #5 | Автор: svr007 | 09.08.16 | from Russian Federation Samara
    После перезагрузки параметр receive-enabled выключен,при этом входящие смс сообщения в inbox не видны, затем включаю receive-enabled=yes,в inbox становится видны входящие смс,и микротик опять начинает обрабатывать смс. Получается микротик помечает входящие смс прочтенными до того момента, пока параметр receive-enabled не станет no,когда он станет yes, микротик отработает все смс с командами которые есть на сим карте
    Планировщика нет.


    #4 | Автор: DmitryAVET | 09.08.16 | from Ukraine
    Проблем не наблюдаю. Все нормально работает. Должен быть включен received-enabled, микротик получает СМС и запускает скрипт - всё просто. После перезагрузки он не может сам запустить повторно скрипт, если это происходит, вероятно, скрипт у вас в планировщике.


    #3 | Автор: svr007 | 09.08.16 | from Russian Federation Samara
    Добрый вечер. Столкнулся с такой проблемой. Если запускать по смс скрипт на перезагрузку или usb power reset, то скрипт выполняется, но отключается receive-enabled, при повторном включение receive-enabled скрипт отправленный ранее по смс опять начинается выполняться и так по кругу. Как у вас этот момент? Я так понимаю при receive-enabled=no микротик входящие смс (которые уже пришли) не видит.


    #2 | Автор: DmitryAVET | 25.07.16 | from Ukraine
    В "/tool sms send" само собой писать номер телефона Администратора, куда отправлять сообщения. Вы же не спрашиваете чей электронный адрес указывать в настройках, когда вас спрашивают email, правда?

    По поводу 3g отчасти согласен, правда power-reset "передергивает" питание, что вовсе не обязательно для переавторизации у провайдера. Это для тех случаев, когда модем повис.


    #1 | Автор: Dobrumir | 25.07.16 | from Russian Federation Kaliningrad
    1) Что за номер телефона нужно вводить, нет пояснения.
    2) Рестартнуть 3G можно /system routerboard usb power-reset

    http://wiki.mikrotik.com/wiki/Manual:USB_Features


    Представьтесь:*
    E-Mail (не публикуется):
     
     
     
     
     
     
    Я ознакомлен(а) и принимаю правила комментирования.
    Включите эту картинку для отображения кода безопасностиНе читабельно? Обновите код!



    Последние заметки в блоге

     
    11.11
    2016
    Скидки в Rozetka.com.ua: ноябрь 2016, промокод ко Дню Шопинга 11.11: Итак, друзья, продолжаем традицию с промокодами. Для тех, кто не... [ Читать ]
    03.11
    2016
    Mikrotik обновил часть своих устройств: новые процессоры и радиомодули для cAP, mAP, OmniTIK 5, OmniTIK 5 PoE, QRT 2, SXT 2, DynaDish 5, SXT HG5 ac, SXT 5 ac, SXT SA5 ac и SXT Lite5 ac: Компания Mikrotik анонсировала большое обновление для своих устройств. Чуть ранее... [ Читать ]
    03.11
    2016
    Обзор маршрутизатора Mikrotik hEX rev.3 (RB750Gr3): аппаратный IPSec, мощный двуядерный процессор, 256 Мб оперативки и поддержка Dude Server: Компания Mikrotik анонсировала обновление маршрутизатора hEX до 3-ей ревизии– RB750Gr3.... [ Читать ]
    03.11
    2016
    Обзор Ubiquiti Rocket 5ac Prism: оптимальное решение для базовых станций и линков PTP по соотношению цена/качество: Год назад, на конференции Ubiquiti NEXT 2015, проходящей в Лас-Вегасе,... [ Читать ]
    01.11
    2016
    Сравнительный обзор EdgePoint EP-R6, EP-R8 и EP-S16: упрощаем коммутацию внутри сети: 12 октября в Лас-Вегасе на ежегодной конференции NEXT 2015 Роберт... [ Читать ]

    Самое популярное

     

    На правах рекламы ↓

     

    Навигация по тегам

     
    802.11ac, 802.11n, Android, DVB-T2, EdgeRouter, Google, hAP, hAP lite, Mikrotik, Parom.TV, RB951, RB951Ui-2HnD, RouterBOARD, RouterOS, Rozetka, rozetka.com.ua, Strong, Strong 8500, Strong SRT 8500, Trimax, Ubiquiti, UBNT, UniFi, Wi-Fi, Winbox, маршрутизатор, настройка, обзор, обновление, онлайн ТВ, планшет, промо, промо-код, прошивка, ресивер, роутер, сайт, скидки, тест, точка доступа

    Показать все теги