Помощь проекту


Отправка Push-уведомлений из Mikrotik RouterOS прямо на мобильный при помощи Telegram

06 май 2018 2 610 11
Ранее в блоге я уже писал о том, как можно осуществлять удаленное управление устройствами Mikrotik под управлением RouterOS при помощи SMS-команд. Тогда же мы рассматривали возможность отправки SMS-уведомлений администратору при отключении основного интернет канала и переключении на 3G-модем.

У меня, как и ранее, нет свободного времени, чтобы адаптировать скрипт «Advanced Failover» под свежие версии RouterOS, так что за это я извиняюсь. По возможности в свободное время займусь.

Сегодня мне бы хотелось поговорить об альтернативе классическим SMS-уведомлениям. В частности, о варианте с отправкой Push-уведомлений прямо на смартфон, планшет или даже ПК (PC, Mac, macOS, Linux). Все это без использования платных сервисов-посредников с минимальными затратами времени.

В данном варианте реализации речь пойдет о сервисе Telegram у которого есть удобный API для управления ботами. На данный вариант я наткнулся чисто случайно, т.к. до недавнего времени про сам Telegram я, конечно же, слышал, но только в общих чертах и сам с ним не сталкивался.

Начинаем работу с Telegram

Первым делом качаем официальное мобильное приложение Telegram, создаем аккаунт. Все ссылки вы можете найти на официальном сайте.

После того, как аккаунт создан, при помощи поиска необходимо найти контакт «BotFather» – это главный бот, при помощи которого можно создавать новых ботов и управлять уже существующими. При желании, боту можно будет поменять имя, а также загрузить для него аватар.

Дальнейшее «общение» с ботом будет происходить в виде текстовых команд. Для создания нового бота, выполните команду:
/newbot

После ввода и отправки данной команды, главный бот запросит отображаемое имя, в нем допускаются пробелы и произвольный формат самого названия.

После указания имени, бот запросит желаемый %username%. При выборе %username% обязательным условием является суффикс «bot» в конце имени, например MikrotikBot или Mikrotik_bot.

Если всё прошло успешно, бот-отец ответит сообщением, содержащим специальный token для доступа к API. Сам токен состоит из двух частей, разделенных двоеточием, например:
12558568:Hgsgf74tv7efcdfvhdvhfvcbn65imghmj

Следующим шагом рекомендуется проверить доступность API для вашего бота, делается это в браузере, путем открытия специального URL:
https://api.telegram.org/bot<ваш_токен>/getMe

Система возвращает ответы в формате JSON, в коде ответа должен присутствовать параметр «ok: true», если он есть – API доступен.
Собственно бот почти готов, осталось только научить Mikrotik отправлять сообщения, используя API Telegram.

Перед тем, как приступить к настройке RouterOS, необходимо узнать ID чата. При помощи мобильного приложения отправляем нашему боту команду:
/start 

После чего, в браузере открываем специальный URL:
https://api.telegram.org/bot<ваш_токен>/getUpdates

В ответе нас интересует параметр message=>chat=>id, в нем хранится уникальный идентификатор чата между вами и созданным ботом. По сути, это ваш идентификатор как пользователя, он будет идентичен для всех ботов в рамках одного аккаунта.

Отправка тестового Telegram-сообщения

Теперь у нас есть все необходимое для того, чтобы отправлять сообщения при помощи API. Отправка сообщений осуществляется при помощи браузера, по специально сформированной ссылке, которая имеет следующий вид:
https://api.telegram.org/bot<ваш_токен>/sendMessage?chat_id=<id_чата>&text=<сообщение>

Параметры:
  • <ваш_токен> – ваш уникальный токен для доступа к API, полученный ранее;
  • <id_чата> – уникальный идентификатор чата, в который будет отправлено сообщение;
  • <сообщение> – текст сообщения;
Текст сообщения может быть как на английском, так и на русском. Для сообщения на латинице, пробелы следует заменять на «%20», точно так же, как это делается в обычных URL.
Для того, чтобы отправить сообщение кириллицей, предварительно текст необходимо конвертировать при помощи urlencode, это встроенная функция PHP. Наиболее простой вариант – воспользоваться любым онлайн сервисом, конвертацию выполняем в кодировку UTF-8.

Отправляем сообщения из Mikrotik RouterOS

Отправить сообщение из RouterOS не составит особых трудностей. Для этого можно воспользоваться следующим кодом:
tool fetch url="https://api.telegram.org/bot<ваш_токен>/sendMessage?chat_id=<id_чата>&text=<сообщение>" dst-path=telegram.txt

Для отладки, вы можете воспользоваться стандартными возможностями System – Scripts. Вот собственно и все, остальное за вами.
Как вариант, данную систему уведомлений можно комбинировать с USB-модемом. Например, при отключении основного интернет-канала, Mikrotik может отправить уведомление, используя резервный канал. При этом данный метод совершенно бесплатен, в отличие от обычных SMS, за которые оператор взымает плату. Единственное ограничение – доступ к Интернет на самом Mikrotik и конечном устройстве с приложением Telegram (для отправки и получения).

Лично я использую Telegram API в связке со встроенным инструментом Netwatch, он предельно прост в использовании и настройке.

Параметры Netwatch:
  • Host – пингуемый узел;
  • Interval – интервал в секундах между попытками проверки, по-умолчанию 1 минута;
  • Timeout – таймаут ожидания, по-умолчанию 1000 мс;
Во вкладках UP и DOWN пишется код, который необходимо выполнить, когда хост доступен или не доступен. Команды (скрипт) выполняются только при смене статуса с up на down или наоборот.

Вариантов применения данного метода существует большое количество, если у вас есть интересная идея или реализация – можете поделиться ею в комментариях.

Видеокурс «Настройка оборудования MikroTik» (аналог MTCNA)

Учитесь работать с MikroTik? Рекомендую видеокурс «Настройка оборудования MikroTik». В курсе разобраны все темы из официальной учебной программы MTCNA и много дополнительного материала. Курс сочетает теоретическую часть и практику – настройку маршрутизатора по техническому заданию. Консультации по заданиям курса ведет его автор Дмитрий Скоромнов. Подойдет и для первого знакомства с оборудованием MikroTik, и для систематизации знаний опытным специалистам.

Интернет-магазин ntools.com.ua

Комментарии:

Добавить
  • bowtiesmilelaughingblushsmileyrelaxedsmirk
    heart_eyeskissing_heartkissing_closed_eyesflushedrelievedsatisfiedgrin
    winkstuck_out_tongue_winking_eyestuck_out_tongue_closed_eyesgrinningkissingstuck_out_tonguesleeping
    worriedfrowninganguishedopen_mouthgrimacingconfusedhushed
    expressionlessunamusedsweat_smilesweatdisappointed_relievedwearypensive
    disappointedconfoundedfearfulcold_sweatperseverecrysob
    joyastonishedscreamtired_faceangryragetriumph
    sleepyyummasksunglassesdizzy_faceimpsmiling_imp
    neutral_faceno_mouthinnocent
  1. Александр Соловьев
    Александр Соловьев Гости 7 июня 2018 13:48
    + 0 -
    При попытке отправить тестовое сообщение через терминал микротика выдает ошибку: "failure: invalid url protocol" подскажите что это
  2. Дмитрий
    Дмитрий Гости 10 мая 2018 17:21
    + 0 -
    Сначала пишет connecting а потом вот:
    status: failed

    failure: closing connection: <404 Not Found> 149.154.167.220:443 (4)
    Подскажите, пожалуйста, что я не так делаю). Спасибо.
    1. DmitryAVET
      DmitryAVET Создатель 10 мая 2018 22:01
      + -1 -
      Неправильно формируете URL, система же отдает вам ответ 404.
  3. Dimon “DimonW” Wek
    Dimon “DimonW” Wek Посетители 6 мая 2018 21:56
    + 0 -
    :global temp1
    :set temp1 40
    :global temp2 [/system health get temperature]
    :if ($temp2 > $temp1) do= {/tool fetch url=("https://api.telegram.org/bot<ваш токен>/sendmessage\?chat_id=IDIDIDID&text=Warning!!! $temp2 temperature. ") keep-result=no}

    на некоторых микротиках есть датчик температуры, таким образом мы можем получать уведомлениеесли в помещении стало жарковато :)
    1. DmitryAVET
      DmitryAVET Создатель 6 мая 2018 23:19
      + 0 -
      у hAP ac2 рабочая от 40 градусов) а под нагрузкой и целых 52 набирает)))
      1. Dimon “DimonW” Wek
        Dimon “DimonW” Wek Посетители 7 мая 2018 18:13
        + 0 -
        в помещении с кондиционером таких температур не будет :)
        1. DmitryAVET
          DmitryAVET Создатель 7 мая 2018 22:54
          + 0 -
          При 23 в помещении греется 45 легко
  4. Алексей
    Алексей Гости 6 мая 2018 16:16
    + 0 -
    Всё встало в самом начале, на абзаце "Следующим шагом рекомендуется проверить доступность API для вашего бота, делается это в браузере, путем открытия специального URL..."

    все браузеры пишут "Не возможно отобразить страницу". Где затык?
    1. DmitryAVET
      DmitryAVET Создатель 6 мая 2018 16:57
      + 0 -
      Проверяли по ссылке?
      https://api.telegram.org/bot<ваш_токен>/getMe

      Где <ваш_токен> меняется на ваш токен.
      Уверен, вы где-то допустили ошибку.
      1. Алексей
        Алексей Гости 7 мая 2018 04:13
        + 0 -
        Через VPN зашёл. Но не так как у вас на картинке - не такая красивая и цветная, - строго текст с информацией. Скорей всего связанно с борьбой Роскомнадзора и Telegram... На нормальной работе бота будет также это отражаться?
        Вот так у меня в браузере, чисто строка с текстом вверху страницы (в одну строку всё):
        {"ok":true,"result":{"id":583514311,"is_bot":true,"first_name":"Mikrotik_blablabla","username":"blablabla_bot"}}
        1. DmitryAVET
          DmitryAVET Создатель 7 мая 2018 09:18
          + 0 -
          Не имеет значения, цветное или нет, просто мой браузер поддерживает json-формат и выполняет подсветку синтаксиса. Ваш либо не поддерживает, либо данная возможность отключена.

          В РФ телеграм заблокирован, насколько я знаю, так что для работы уведомлений необходимо, чтобы у роутера был доступ к сервису Telegram. Как вы это реализуете - без разницы.

          Само собой разумеется, на смартфоне у вас также должен быть доступ к Telegram.

Разбираемся с «Detect Internet» в RouterOS 6.41

Начиная с обновления RouterOS 6.41 разработчики добавили функцию detect-internet, которая позволяет определять статус интерфейсов. Для чего можно...

Как подружить FastTrack и IPsec в Mikrotik RouterOS?

В одной из предыдущих публикаций я описывал способ маркировки нужного трафика и его последующую отправку в VPN. Одной из негативных сторон описанного...

Управление Mikrotik удаленно при помощи SMS

В двух предыдущих публикациях я уже рассказывал, как можно очень просто подключить 3G-модем к маршрутизаторам Mikrotik и настроить автоматическое...

Mikrotik Advanced Failover: автоматическое переключение между основным каналом

В рамках вводной публикации, опубликованной ранее, были изложены основные моменты подключения 3G-модема к маршрутизатору Mikrotik, на примере Huawei...

Построение сети HotSpot на Mikrotik: Часть 2. Настройка CAPsMAN, удаленное

Чуть ранее мы опубликовали инструкцию по созданию и настройке HotSpot на маршрутизаторах Mikrotik под управлением операционной системы RouterOS. В...

Создание и настройка HotSpot на оборудовании Mikrotik под управлением RouterOS

Жизнь современного активного человека немыслима без смартфона и постоянного доступа к сети Интернет. Всё это приводит к необходимости создания...


авторизация на сайте

Войти при помощи Вконтакте Войти при помощи Facebook Войти при помощи Google+ Войти при помощи Яндекс
Забыли пароль?