Mikrotik работает над поддержкой 802.11ac Wave 2 в RouterOS v7.1

14 декабрь 2020 2 356 7
Рынок беспроводных устройств и сами стандарты беспроводной связи не стоят на месте, из года в год предлагая пользователям новые функциональные возможности. Если еще пару лет назад только пионеры предлагали поддержку 802.11 Wave 2 в своих беспроводных решениях, то на сегодня поддержка таких технологий как MU-MIMO и Beamforming имеется даже в бюджетных решениях нижнего ценового сегмента.

Для общего понимания, редакция Wave 2 была принята еще в 2016-м году. На официальном форуме Mikrotik, пользователи неоднократно ругали латвийскую компанию за отсутствие поддержки 802.11ac Wave 2. Поддержка каналов 160 МГц была добавлена еще в 2017-м году, начиная с версий 6.41 RC. Собственно, на этом внедрение поддержки Wave 2 закончилось. В одной из веток представители Mikrotik, отвечая на вопрос о поддержке 802.11ac Wave 2 сослались на необходимость переписывания драйверов и ядра. Как сообщал представитель Mikrotik, реальная польза от новых возможностей Wave 2 несопоставима с затратами на переписывания ядра и драйверов.

В начале 2019-го года представитель компании сообщил, что Mikrotik работает над новыми беспроводными драйверами.

Анонс RouterOS 7.1 beta 3

И только 3-го декабря 2020-го года, с анонсом RouterOS 7.1beta3, в списке изменений засветилась поддержка нового пакета под названием wifiwave2.

Бета-версия пакета wifiwave2 предлагает новый драйвер беспроводной сети, поддерживающий новые функции, добавленные стандартом 802.11ac Wave 2. Установка данного пакета пока возможна исключительно как часть RouterOS 7.1beta3 в составе дополнительного пакета (extra package).

Следует брать во внимание, что пакет wifiwave2 тестовый и его установка отключает старый wireless interface, а также CAPsMAN. После установки пакета старый интерфейс будет недоступен, вместо него будет доступно новое альтернативное меню конфигурации.

Требования WifiWave2

Пакет wifiwave2 совместим с беспроводными интерфейсами чипов Qualcomm IPQ4019 и QCA9984, запущенных на тестовых сборках RouterOS v7 для платформы для ARM.
Если Вы хотите научиться настраивать MikroTik, предлагаем пройти онлайн обучение. Более подробную информацию Вы можете найти в конце данной публикации.

Для поддержки пакета требуется 10 МБ свободного места на накопителе и не менее 256 МБ оперативной памяти. Таким образом, на сегодня wifiwave2 совместим только с 4 моделями:
  • hAP ac³ (без LTE)
  • Audience
  • Audience LTE6
  • RB4011iGS+5HacQ2HnD
Но даже тут есть свои оговорки. Во-первых, пакет wifiwave2 не совместим с CAPsMAN. Во-вторых, на платформе RB4011 с пакетом wifiwave2 реализована поддержка только сетей 5 ГГц, иными словами, диапазон 2.4 ГГц работать не будет.

Новые возможности 802.11ac Wave 2

Что же нового нам обещают?
  • поддержка аутентификации WPA3 с шифрованием OWE (Opportunistic Wireless Encryption);
  • добавлена поддержка 802.11w (Protected Management Frames);
  • базовая поддержка MU-MIMO и Beamforming;
  • поддержка канальной скорости 400 Мбит для диапазона 2.4 ГГц на интерфейсах с чипами IPQ4019;

Базовая настройка WifiWave2

Беспроводные интерфейсы wifiwave2 на текущий момент можно настроить исключительно через интерфейс командной строки (CLI) в соответствующем меню /interface/wifiwave2.

Любое другое конфигурирование, включая графический интерфейс WinBox или WebFig в настоящее время не поддерживаются.
Синтаксис базовой конфигурации имеет следующий вид:
/interface/wifiwave2 set wifi1 disabled=no ssid=WEBLANCE \
security.authentication-types=wpa2-psk,wpa3-psk security.passphrase=_min_8_max_63_symbols_
Если же предполагается использование OWE, конфигурация примет следующий вид:
/interface/wifiwave2
add master=wifi1 name=wifi1_owe ssid=WEBLANCE-OWE \
security.authentication-types=owe security.owe-tranistion-interface=wifi1 \
configuration.hide-ssid=yes
set wifi1 ssid=WEBLANCE security.authentication-types="" security.owe-transition-interface=wifi1_owe
enable wifi1,wifi1_owe
Более подробную информацию о WifiWave2 вы можете найти на официальном wiki.

Как видим, реализация Wave 2 еще очень и очень сырая, до её полноценного внедрения пройдет немало времени и, судя по всему, сам Wave 2 будет доступен начиная с RouterOS v7.1+. Будет ли доступен этот пакет для версий RouterOS v6 – не ясно, вполне возможно, что для поддержки нового стека требуется более новая версия Linux Kernel, нежели та, которая взята за основу 6-й версии ROS.

Также не известна судьба wifiwave2 на более старых устройствах по типу wAP ac, hAP ac, hAP ac lite. На текущий момент идет публичное тестирование новой версии для платформы ARM, хотя в самой компании ранее заявили, что работы над ROS 7 параллельно идут для всех имеющихся платформ.

Также со стороны компании пока не поступало официальной информации и позиции относительно поддержки стандартов 802.11k, 802.11v и 802.11r, обеспечивающих поддержку беспроводного роуминга между точками.

То же самое касается поддержки Band Steering, касаемо которого несколько лет назад представитель Mikrotik высказался, что клиенты и без того сами выбирают 5 ГГц и ничего делать не требуется.

Видеокурс «Настройка оборудования MikroTik» (аналог MTCNA)

Учитесь работать с MikroTik? Рекомендую видеокурс «Настройка оборудования MikroTik». В курсе разобраны все темы из официальной учебной программы MTCNA и много дополнительного материала. Курс сочетает теоретическую часть и практику – настройку маршрутизатора по техническому заданию. Консультации по заданиям курса ведет его автор Дмитрий Скоромнов. Подойдет и для первого знакомства с оборудованием MikroTik, и для систематизации знаний опытным специалистам.

Интернет-магазин ntools.com.ua

Комментарии:

Добавить
  • bowtiesmilelaughingblushsmileyrelaxedsmirk
    heart_eyeskissing_heartkissing_closed_eyesflushedrelievedsatisfiedgrin
    winkstuck_out_tongue_winking_eyestuck_out_tongue_closed_eyesgrinningkissingstuck_out_tonguesleeping
    worriedfrowninganguishedopen_mouthgrimacingconfusedhushed
    expressionlessunamusedsweat_smilesweatdisappointed_relievedwearypensive
    disappointedconfoundedfearfulcold_sweatperseverecrysob
    joyastonishedscreamtired_faceangryragetriumph
    sleepyyummasksunglassesdizzy_faceimpsmiling_imp
    neutral_faceno_mouthinnocent
  1. XDefender
    XDefender Гости 7 февраля 2021 20:45
    + 0 -
    Если сейчас не перепишут, то им не видать работы с WiFi 6E/7.... т.к. MU-MIMO - одна из базовых составляющих... и кроме того, им все нужно переписать поддерживая многопоточность, а не как сейчас..
  2. Dmitry
    Dmitry Гости 21 декабря 2020 03:07
    + 0 -
    Если новый драйвер в перспективе не будет работать на устройствах в 16 мб внутренней памяти и 128, то это полный фейл. Тот же Hap AC2, Cap Ac без проблем могут работать с Wave2 при наличии драйвера. Забавно то что TP-Link с Wave 2 работает на жедезках с 8 мб встроенной памяти и 64 мб ОЗУ(по моему даже есть на 32 мб озу устройства с поддержкой wave 2 у них)...
  3. Ваше имя
    Ваше имя Гости 16 декабря 2020 06:28
    + 0 -
    С ответа про бэнд стиринг хохотнул.
    1. Мое имя
      Мое имя Гости 8 марта 2021 00:24
      + 0 -
      у меня hap ac2 с 256MB RAM, но поддержки wave2 нет.
      mikrotik разочаровал.
  4. Вася Пупкин
    Вася Пупкин Гости 15 декабря 2020 14:24
    + +2 -
    ну раз так, давай прощаться, микротик.
    1. Джон Сноу
      Джон Сноу Гости 16 декабря 2020 10:45
      + 0 -
      А чем заменим?
      1. Евгэн.
        Евгэн. Гости 25 марта 2021 23:51
        + 0 -
        tp-link deco/Tenda nova для вайфая. Микротик для проводов/NAT можно и оставить

Обзор netis N4 и W1: 5 ГГц в сегменте роутеров N300

Несколько месяцев назад, еще в сентябре, в мои руки попали 2 новых маршрутизатора от компании netis. Закономерный вопрос, почему так долго выходил...

В Mikrotik работают над новыми устройствами 60 ГГц с поддержкой 802.11ay: новый

Не успели на рынке появиться первые решения с поддержкой стандарта 802.11ad, как вслед за ними Qualcomm представил чипы с поддержкой новейшего...

Mikrotik готовит платформу RB4011 на базе процессоров Alpine, заявлена

Обсуждение платформы RB3011 длится достаточно давно. В частности, пользователи неоднократно спрашивали у представителей Mikrotik, будет ли...

Tenda представила маршрутизатор Tenda AC5: перенос учетных данных PPPoE,

Компания Tenda Technology представила новый двухдиапазонный смарт-маршрутизатор Tenda AC5 з поддержкой функции переноса учетных данных. Tenda AC5 –...

Стандарт 802.11ac Wave 2: MU-MIMO и другие возможности. Самый полный FaQ по

В свете выхода новых беспроводных устройств с поддержкой технологии MU-MIMO, в частности с выходом UniFi AC HD (UAP-AC-HD), назрела необходимость в...

Обзор Mikrotik SXT Lite 5 ac: реальная скорость и отличия от предыдущей версии

Не так давно компания Mikrotik представила обновленную версию SXT Lite 5 с поддержкой стандарта 802.11ac, получившую название SXT Lite 5 ac. Сразу же...

авторизация на сайте

Войти при помощи Facebook Войти при помощи Google+
Забыли пароль?