Обход блокировки сайтов со стороны провайдера на Mikrotik (RouterOS) при помощи Policy Based Routing

18 май 2017 20 611 84

В рамках данной публикации мне хотелось бы поговорить об одном из методов обхода блокировки сайтов со стороны провайдера на маршрутизаторах Mikrotik под управлением RouterOS.

Бывают такие ситуации, когда провайдер блокирует доступ к некоторым ресурсам. Зачастую, блокировка ресурсов осуществляется на базе URL, IP и DNS, многое, конечно же, зависит от типа и возможностей оборудования, применяемого самим провайдером.

Блокировка по IP – один из популярных методов, при котором запрет осуществляется на базе конечного IP-адреса ресурса, это также может быть диапазон IP или же несколько диапазонов (для очень больших проектов).

Блокировка по DNS сводится к запрету, исключению либо подмене конечного IP для заданного домена. По сути, данный метод блокировки обходится довольно просто, путем замены DNS провайдера на сторонние, к примеру Google DNS (8.8.8.8, 8.8.4.4), Yandex DNS (базовый: 77.88.8.8, 77.88.8.1; безопасный: 77.88.8.88, 77.88.8.2; семейный 77.88.8.7, 77.88.8.3) или любой другой, который вашей душе угоден.

Серьезные провайдеры могут использовать так называемый DPI (Deep packet inspection), который по-сути, является глубоким анализов пакетов. DPI способен блокировать ресурсы не только по IP или DNS, но и при использовании прокси-серверов (Proxy) или других незащищенных каналов передачи.

В случае с простой блокировкой IP, обход осуществляется без проблем при помощи любого прокси-анонимайзера или любого VPN.

В случае с DPI, всё куда более сложнее, т.к. система анализирует не только заголовки пакетов, конечного получателя и т.д., но и содержимое пакета, копаясь в передаваемых данных, тем самым может даже нарушать законодательство, если, конечно же, в пользовательском соглашении нет мелкого шрифта. Возможности DPI очень широки и при желании, провайдер может даже запретить вам использовать OpenVPN.

Сегодня мы не будем рассматривать все методы обхода всех видов блокировки, а лишь рассмотрим один из вариантов реализации обхода, который предложен в официальной документации Mikrotik (Policy Based Routing).

Предполагается, что заранее у вас уже должен быть маршрутизатор на RouterOS, если такого не имеется - по выгодной цене маршрутизаторы Mikrotik можно приобрести в интернет-магазине Gigahertz.

Наиболее простой вариант обхода – использовать серверы VPN. Причем заблокированные ресурсы можно открывать через VPN, а все оставшиеся – через провайдера.

У данного метода существует ряд преимуществ. Одно из главных достоинств данного метода состоит в том, что вы будете использовать лишь часть пропускной способности VPN. Дело в том, что сервисы VPN обычно находятся далеко заграницей и каналы к ним сильно загружены, поэтому направляя через тоннель весь трафик, скорость доступа будет падать, причем как для заблокированных ресурсов, так и для всех остальных.

Из дополнительных преимуществ данного метода можно отметить отсутствие необходимости настройки VPN на всех клиентских устройствах, особенно если это смартфон. Хотя для смартфонов существует достаточное количество бесплатных приложений, реализующих необходимый функционал.

Есть у данного способа и недостаток – поиск оптимального VPN-сервиса, как вариант, покупка премиум-аккаунта.

Создание списка адресов (пример)

К примеру, у нас есть листинг из заблокированных адресов. В качестве примера у нас 4 списка: ВКонтакте, Одноклассники, Yandex и Mail.ru.

Все диапазоны в виде команд для Mikrotik, для простоты добавление. Некоторые спросят, а почему не объединить все ресурсы в один список? Ответ очень простой, при изменении всего одного интернет-ресурса, вы будете вынуждены пересматривать весь список, т.к. по одним подсетям вы ориентироваться будет сложно.

Адреса можно добавлять как вручную через терминал из WinBox > New Terminal.

Список подсетей для ресурсов ВКонткте

/ip firewall address-list
add address=87.240.128.0/18 list=vkcom
add address=93.186.224.0/20 list=vkcom
add address=95.142.192.0/20 list=vkcom
add address=95.213.0.0/17 list=vkcom
add address=185.32.248.0/22 list=vkcom
add address=95.213.0.0/18 list=vkcom
add address=95.142.207.0/24 list=vkcom
add address=95.142.206.0/24 list=vkcom
add address=95.142.204.0/23 list=vkcom
add address=95.142.203.0/24 list=vkcom
add address=95.142.202.0/24 list=vkcom
add address=95.142.201.0/24 list=vkcom
add address=95.142.200.0/21 list=vkcom
add address=95.142.192.0/21 list=vkcom
add address=93.186.232.0/21 list=vkcom
add address=93.186.224.0/21 list=vkcom
add address=185.32.251.0/24 list=vkcom
add address=185.32.250.0/24 list=vkcom
add address=185.32.248.0/23 list=vkcom
add address=185.29.130.0/24 list=vkcom
Либо предварительно загрузив в память микротика необходимые списки в виде командных файлов с разрешением RSC. Файлы в Mikrotik загружаются путем обычного петаскивания на окно WinBox > Files. Или же при помощи кнопки Upload, если Drag-n-Drop по каким-то причинам не работает. После чего импортируете списки командой:
import file=vkcom.rsc
Где vkcom.rsc - название файла со списком.
   

Список подсетей для ресурсов Яндекса (в т.ч. КиноПоиск)

/ip firewall address-list
add address=5.45.192.0/18 list=yandex
add address=5.255.192.0/18 list=yandex
add address=37.9.64.0/18 list=yandex
add address=37.140.128.0/18 list=yandex
add address=77.88.0.0/18 list=yandex
add address=84.201.128.0/18 list=yandex
add address=87.250.224.0/19 list=yandex
add address=93.158.128.0/18 list=yandex
add address=95.108.128.0/17 list=yandex
add address=100.43.64.0/19 list=yandex
add address=130.193.32.0/19 list=yandex
add address=141.8.128.0/18 list=yandex
add address=178.154.128.0/17 list=yandex
add address=199.21.96.0/22 list=yandex
add address=199.36.240.0/22 list=yandex
add address=213.180.192.0/19 list=yandex
add address=93.158.134.0/24 list=yandex
add address=87.250.255.0/24 list=yandex
add address=87.250.254.0/24 list=yandex
add address=87.250.251.0/24 list=yandex
add address=87.250.250.0/24 list=yandex
add address=87.250.247.0/24 list=yandex
add address=77.88.8.0/24 list=yandex
add address=77.88.55.0/24 list=yandex
add address=77.88.54.0/24 list=yandex
add address=77.88.44.0/24 list=yandex
add address=77.88.35.0/24 list=yandex
add address=77.88.21.0/24 list=yandex
add address=77.75.159.0/24 list=yandex
add address=77.75.152.0/22 list=yandex
add address=5.45.240.0/24 list=yandex
add address=5.45.232.0/24 list=yandex
add address=5.45.229.0/24 list=yandex
add address=5.45.217.0/24 list=yandex
add address=5.45.213.0/24 list=yandex
add address=5.45.205.0/24 list=yandex
add address=5.45.196.0/24 list=yandex
add address=5.255.255.0/24 list=yandex
add address=5.255.200.0/24 list=yandex
add address=5.255.196.0/24 list=yandex
add address=5.255.195.0/24 list=yandex
add address=37.9.112.0/24 list=yandex
add address=213.180.204.0/24 list=yandex
add address=213.180.202.0/24 list=yandex
add address=213.180.199.0/24 list=yandex
add address=213.180.193.0/24 list=yandex
add address=185.71.79.0/24 list=yandex
add address=185.71.78.0/24 list=yandex
add address=185.71.77.0/24 list=yandex
add address=185.71.76.0/24 list=yandex
add address=185.71.76.0/22 list=yandex
add address=185.32.186.0/24 list=yandex
add address=185.32.185.0/24 list=yandex
add address=178.154.170.0/24 list=yandex
add address=178.154.131.0/24 list=yandex
add address=109.235.165.0/24 list=yandex
add address=109.235.160.0/21 list=yandex
add address=100.43.87.0/24 list=yandex
   

Список подсетей для Одноклассники.ru

/ip firewall address-list
add address=5.61.16.0/21 list=okru
add address=5.61.232.0/21 list=okru
add address=79.137.157.0/24 list=okru
add address=79.137.183.0/24 list=okru
add address=94.100.176.0/20 list=okru
add address=95.163.32.0/19 list=okru
add address=128.140.168.0/21 list=okru
add address=178.22.88.0/21 list=okru
add address=178.237.16.0/20 list=okru
add address=185.5.136.0/22 list=okru
add address=185.6.247.0/24 list=okru
add address=185.16.244.0/22 list=okru
add address=188.93.56.0/21 list=okru
add address=194.186.63.0/24 list=okru
add address=195.211.20.0/22 list=okru
add address=195.218.168.0/24 list=okru
add address=195.218.190.0/23 list=okru
add address=217.20.144.0/20 list=okru
add address=217.69.128.0/20 list=okru
   

Список подсетей для ресурсов Mail.ru

/ip firewall address-list
add address=5.61.16.0/21 list=mailru
add address=5.61.232.0/21 list=mailru
add address=79.137.157.0/24 list=mailru
add address=79.137.183.0/24 list=mailru
add address=94.100.176.0/20 list=mailru
add address=95.163.32.0/19 list=mailru
add address=128.140.168.0/21 list=mailru
add address=178.22.88.0/21 list=mailru
add address=178.237.16.0/20 list=mailru
add address=185.5.136.0/22 list=mailru
add address=185.6.247.0/24 list=mailru
add address=185.16.244.0/22 list=mailru
add address=188.93.56.0/21 list=mailru
add address=194.186.63.0/24 list=mailru
add address=195.211.20.0/22 list=mailru
add address=195.218.168.0/24 list=mailru
add address=195.218.190.0/23 list=mailru
add address=217.20.144.0/20 list=mailru
add address=217.69.128.0/20 list=mailru
add address=195.211.21.0/24 list=mailru
add address=195.211.22.0/24 list=mailru
add address=195.211.20.0/24 list=mailru
add address=208.87.94.0/24 list=mailru
add address=195.211.130.0/23 list=mailru
add address=195.211.128.0/24 list=mailru
add address=195.211.128.0/23 list=mailru
add address=195.211.128.0/22 list=mailru
add address=185.16.244.0/23 list=mailru
add address=185.16.148.0/22 list=mailru
add address=128.140.170.0/24 list=mailru
Скачать список для MailRU - mailru.rsc [1,22 Kb] (cкачиваний: 617)
   

Списки адресов находятся в разделе IP – Firewall – Address Lists.


Маркировка пакетов

Для того, чтобы отобрать только заблокированные ресурсы, необходимо найти и промаркировать необходимые пакеты. Делается это в IP – Firewall – Mangle.

При создании указываем следующие параметры:

chain=prerouting

action=mark-routing

dst-address-list=mailru (список адресов)

src-address=192.168.106.0/24 (локальная подсеть)

Вместо 192.168.106.0/24 необходимо указывать свою локальную подсеть, из которой будут идти обращения. Как несложно догадаться, dst-address-list это конечный адрес (из списка). Для всего трафика, удовлетворяющего данным условиям, будет установлена соответствующая метка Traffic_XXXXX.


/ip firewall mangle
add action=mark-routing chain=prerouting comment="Mark mail.ru" dst-address-list=mailru new-routing-mark=Traffic_mailru passthrough=no src-address=192.168.106.0/24
add action=mark-routing chain=prerouting comment="Mark ok.ru" dst-address-list=okru new-routing-mark=Traffic_okru passthrough=no src-address=192.168.106.0/24
add action=mark-routing chain=prerouting comment="Mark vk.com" dst-address-list=vkcom new-routing-mark=Traffic_vkcom passthrough=no src-address=192.168.106.0/24
add action=mark-routing chain=prerouting comment="Mark Yandex" dst-address-list=yandex new-routing-mark=Traffic_yandex passthrough=no src-address=192.168.106.0/24

Создание VPN-подключения

В качестве примера воспользуемся бесплатным сервисом VPN PPTP – SuperFreeVPN. Для примера выберем сервер, расположенный в Лондоне (Великобритания) – IP 77.92.68.65 (uk.superfreevpn.com), логин free, пароль 1891. Обратите внимание, тип подключения PPTP либо L2TP. Минусом конкретно данного сервиса является то, что он постоянно меняет пароли для подключения к серверу, мы же используем его исключительно в качестве примера.


Создание подключения к VPN осуществляется в разделе PPP – Interface, нажимаем синий плюс и выбираем необходимый тип подключения.

/interface pptp-client
add comment="VPN Failover" connect-to=uk.superfreevpn.com disabled=no name=pptp-to-freevpn password=1891 user=free

 

Важно! Не используйте опцию «Add Default Route», в противном случае весь трафик пойдет через VPN.

Обратите внимание, некоторые серверы могут, как требовать шифрование, так и не использовать его вовсе, поэтому если соединение не удалось – проверьте используемый профиль подключения (PPP – Profiles). Для L2TP, в лучшем случае, используется MPPE 128-bit, который уже давным-давно скомпрометирован.


Лучшим вариантом будет использование OpenVPN, в частности с премиум-аккаунтом. Также не забывайте, что RouterOS не поддерживает пока TLS для OpenVPN.

Большинство бесплатных серверов могут быть нестабильны как в плане доступности, так и в плане скорости. К тому же, никто не гарантирует сохранности ваших личных данных. С учетом вышесказанного, к выбору поставщика услуг стоит подойти ответственно. Как минимум, всегда используйте защищенное соединение (HTTP) при работе с сайтами.

Настройка маскарадинга

Сам Mikrotik уже знает про новый шлюз, а для того, чтобы ресурсами VPN-канала смогли пользоваться другие пользователи локальной сети, необходимо настроить маскарадинг.

Делается это в разделе IP – Firewall – NAT. Для out-interface обязательно следует указать правильное название вашего VPN-подключения.

/ip firewall nat
add action=masquerade chain=srcnat out-interface=pptp-to-freevpn

 

Добавление статических маршрутов

После настройки маскарадинга переходим к завершающему шагу – созданию статических маршрутов. Делается это в разделе IP – Routers.

/ip route
add comment="Route MAIL.RU" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_mailru
add comment="Route OK.RU" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_okru
add comment="Route VK.COM" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_vkcom
add comment="Route YANDEX" distance=1 gateway=pptp-to-freevpn routing-mark=Traffic_yandex

При создании маршрутов конечный адрес задаем как и для обычного интернет подключения –0.0.0.0/0, в качестве шлюза (gateway) необходимо указать VPN-подключение (в нашем случае pptp-to-freevpn). Обязательно выбираем routing-mark из выпадающего списка. Таким образом мы создаем статический маршрут для промаркированного трафика.


Вот собственно и всё, если всё проделано верно, а VPN рабочий – вы сможете получить доступ к необходимым ресурсам. Также можете почитать официальную документацию Mikrotik по Policy Base Routing.

Как узнать IP определенного сайта?

Чуть выше, в качестве примера, опубликованы общие списки IP-адресов и диапазонов, принадлежащих соответствующим ресурсам. Списки предоставлен как есть, без претензий к их точности. Настоятельно рекомендую формировать список самостоятельно, так сказать «под себя».

В случае с обычными интернет-сайтам, обычно требуется добавить всего 1-2 IP-адреса, в то время как для больших проектов может использоваться несколько диапазонов. Как же найти все IP по определенному сайту?

В качестве наиболее простого варианта, из под Windows (вызов командной строки – комбинация Win+R) можно использовать стандартную команду:

nslookup <домен>
Использование команды nslookup в Windows
Недостатком такого метода является получение неполного списка адресов - некоторые сервисы могут отдавать всего 2 записи из Х, а на следующий день они уже могуть стать другими. Для поиска наиболее полного списка всех адресов, можно воспользоваться специальными сервисами. При помощи поиска от Hurricane Electric, можно производить поиск, как по доменному домену (например, youtube.com), так и по названию компании, которая владеет пулом адресов (например, Youtube либо YouTube, LLC).

Редактирование, обновление и добавление новых ресурсов

Еще одним неоспоримым преимществом раздельных списков является то, что в любой момент можно добавлять, удалять или изменять отдельные списке, при этом остальные ресурсы не будут затронуты.
Список подсетей для Лаборатории Касперского
/ip firewall address-list
add address=93.159.230.0/23 list=kaspersky
add address=93.159.228.0/23 list=kaspersky
add address=93.159.224.0/22 list=kaspersky
add address=91.103.64.0/21 list=kaspersky
add address=77.74.183.0/24 list=kaspersky
add address=77.74.180.0/22 list=kaspersky
add address=77.74.178.0/23 list=kaspersky
add address=77.74.177.0/24 list=kaspersky
add address=77.74.176.0/24 list=kaspersky
add address=185.85.15.0/24 list=kaspersky
add address=185.85.14.0/24 list=kaspersky
add address=185.85.12.0/24 list=kaspersky
add address=185.54.221.0/24 list=kaspersky
add address=185.54.220.0/24 list=kaspersky
   

Ну и, конечно же, чтобы начать обработку нового списка, необходимо создать новый мангл (промаркировать пакеты) и статический маршрут для нового списка (общий принцип описан выше).

Что делать, если Policy Based Routing медленно работает?

На некоторых конфигурациях может возникнуть проблема, суть которой состоит в том, что при прямом подключении по VPN на ПК – всё работает быстро, но если настроить Policy Based Routing по вышеуказанному примеру в Mikrotik, сайты начинают открываются медленно.

Проблема решается отключением FastTrack в IP – Firewall – Filter Rules.



Поддержка FastTrack была добавлена, начиная с RouterOS 6.29, если кратко, функция позволяет пересылать некоторые пакеты без дополнительно обработки. В некоторых конфигурациях, данная функция позволяет существенно (в несколько раз) ускорить обработку пакетов и понизить нагрузку на процессор.  

Что делать, если провайдер делает подмену DNS-записей?

Для того, чтобы показывать клиенту страницу-заглушку, вместо конечного URL, провайдеры практикуют подмену DNS-записей. Проверить это очень легко: открываем командную строку и делаем tracert для необходимого домена, после чего проверяем whois для конечного IP, который асоциирован с доменным именем. Если IP не принадлежит конечному ресурсу, значит имеет место подмена DNS-записи.

В таком случае, если вы используете DNS провайдера, при подключении по VPN, для конечного домена будет использоваться IP, предоставленный провайдером. Поэтому, при обращении к домену даже через VPN, в конечном итоге, вы обратно попадете на страницу с заглушкой (если это внешний IP) либо получите ошибку "сервер не найден" (если IP недоступен). В этом случае необходимо отказаться от использования DNS провайдера (use-peer-dns=no), например:


/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no interface=ether1-gateway use-peer-dns=no

Либо через интерфейс Winbox: зайти в подменю IP - DHCP Client, выбрать свое подключение к Интернет и отключить в его профиле опцию "Use Peer DNS".

Далее необходимо задействовать сторонние DNS-серверы, например Google DNS (8.8.8.8, 8.8.4.4), Яндекс DNS (77.88.8.8, 77.88.8.1) и/или любой другой сервер:

/ip dns
set allow-remote-requests=yes cache-size=1024KiB query-server-timeout=1s servers=8.8.8.8,8.8.4.4,77.88.8.8,77.88.8.1

После чего выполняетм очистку кеша DNS-записей:

/ip dns cache flush

Либо в Winbox: в разделе IP - DNS - Cache - Flush Cache.

Что делать, если провайдер перехватывает обращения к стороннему DNS?

На практике возможны случаи, когда провайдер перехватывает обращения к внешним DNS-сервисам (используя DNAT), возвращая при этом клиенту измененный ответ от сервера, в котором можно сразу подставить страницу с заглушкой. В этом случае все обращения к внешнему DNS также необходимо заворачивать в VPN, например:

/ip firewall address-list
add address=8.8.8.8 list=dns
add address=8.8.4.4 list=dns
add address=77.88.8.8 list=dns
add address=77.88.8.1 list=dns

/ip firewall mangle
add action=mark-routing chain=prerouting comment="Mark DNS traffic" dst-address-list=dns new-routing-mark=Traffic_dns passthrough=no src-address=192.168.106.0/24

/ip route
add check-gateway=ping comment="Route DNS" distance=1 gateway=l2tp-to-germany routing-mark=Traffic_dns

Есть у данного метода и минус: при подключении к серверу VPN по dns-имени, может возникнуть проблема, связанная с невозможностью получения IP, т.к. подключение по имени, а ответы от DNS принимаются только внутри тонеля.

Интернет-магазин ntools.com.ua

Комментарии:

Добавить
  • bowtiesmilelaughingblushsmileyrelaxedsmirk
    heart_eyeskissing_heartkissing_closed_eyesflushedrelievedsatisfiedgrin
    winkstuck_out_tongue_winking_eyestuck_out_tongue_closed_eyesgrinningkissingstuck_out_tonguesleeping
    worriedfrowninganguishedopen_mouthgrimacingconfusedhushed
    expressionlessunamusedsweat_smilesweatdisappointed_relievedwearypensive
    disappointedconfoundedfearfulcold_sweatperseverecrysob
    joyastonishedscreamtired_faceangryragetriumph
    sleepyyummasksunglassesdizzy_faceimpsmiling_imp
    neutral_faceno_mouthinnocent
  1. Артем Просто Артем
    Артем Просто Артем Посетители 27 сентября 2017 20:55
    + 0 -
    Не знаю больше где спросить помощи, возможно кто-то прочтет и сможет помочь. Хочу поднять на VPS, CHR от Mikrotik. Получить на нем свой VPN который пускал бы через себя только определенные сайты.
    В итоге основная часть получилась, на CHR поднять PPTP сервер, но подключаясь к нему впнизируется весь мой траффик. Подскажите это вообще возможно, чтоб через VPN шли только нужные мне сайты, а остальное шло напрямую?
  2. foxportal
    foxportal Гости 10 августа 2017 16:55
    + 0 -
    Спасибо за мануал. Настроил, но работает только на одном компьютере. Второй компьютер в той же подсети, но не как не могу открыть на нем странички. Соединение через PPTP на https://www.vpnbook.com/. Подскажите где я ошибся?
    1. Дима Плут
      Дима Плут Посетители 11 августа 2017 09:15
      + 0 -
      Вы бы по подробнее описали какие странички не открываются? Как настроена локальная сеть через мастер порт или через бридж? На компьютерах стоит получение IP по DHCP или вручную? Не наставили ли вы до этого впн или прокси подключения на проблемном пк?... итп.
      1. foxportal
        foxportal Гости 14 августа 2017 12:13
        + 0 -
        IP по DHCP получают все компьютеры. Локальная сеть работает через мастер порт. В порт 2 Mikrotik подключен неуправляемый коммутатор, а в него другие ПК. Только на одном есть vk, а но других нет. Почему?
  3. Дима Плут
    Дима Плут Посетители 10 августа 2017 11:54
    + +1 -
    Автору спасибо за разжованую и частично переваренную инструкцию :) Есть вопрос, все настроил дома по инструкции все прекрасно. Теперь хочу подключатся к данному микроту по впн со смартфона и получать те же маршруты что и дома. Создал pptp подключение, трафик со смарта пошел через домашний микротик но никак не могу заставить работать смарт по тем же маршрутам что и локальные пользователи. Подскажите как это правильно сделать?
  4. Hamster77
    Hamster77 Посетители 1 августа 2017 09:32
    + 0 -
    Здравствуйте. Спасибо за статью - заработало! Подскажите как настроить сервис vpn99_net, а то бесплатный работает, а vpn99_net конектиться, но ping не работает! Может кто-нибудь подскажет?
    1. DmitryAVET
      DmitryAVET Создатель 1 августа 2017 09:46
      + 0 -
      Пробуйте для проверки без правил и всего прочего вообще подключить VPN, не забудьте включить для соединения маскарадинг.
    2. Grigoriy
      Grigoriy Гости 1 августа 2017 12:12
      + 0 -
      Я пытался настроить подобным способом на другом роутере N56U с помощью сервиса VPN99 - вообще не захотело работать, они что-то блокируют и возможно по этому не работает. Как только я вбил впн от frootvpn - все сразу стало ок! На микротике процесс несколько другой, но возможно проблема именно в впн99.
    3. zilf
      zilf Посетители 1 августа 2017 14:15
      + 0 -
      У меня vpn99 отлично работает. Вбил в Connect To: ru.vpn99.net имя пользователя и пароль, еще поменял MaxMTU на 1320 и все работает.
      1. Hamster77
        Hamster77 Посетители 1 августа 2017 22:00
        + 0 -
        Поделитесь пожалуйста настройками, сделал все как написано в статье Микротик на бесплатном работает, а вот на vpn99 не работает даже с MaxMTU 1320! Может Вы что-нибудь еще настраивали?
    4. zilf
      zilf Посетители 2 августа 2017 08:18
      + 0 -
      Да все делал строго по инструкции. Создал PPTP client и настроил:
      https://drive.google.com/open?id=0B1HBhB2Z1S2hUE1rclBHSmtqdU0
      1. Hamster77
        Hamster77 Посетители 19 августа 2017 15:27
        + 0 -
        Спасбо за ответ! Вообщем конект есть с самого начала, НО пакеты к вышеуказаным сайтам не ходят! Думаю проблема у "этого" провайдера в IP адрессах и маске подсети:255.255.255.255 Ребята, кто запустил этот VPN на VPN99 при помощи mikrotik?
  5. Toshick
    Toshick Гости 26 июля 2017 11:41
    + +1 -
    Оставлю это здесь. Как исключить впн из фасттрека:
    https://schemen.me/mikrotik-fast-track-that-excludes-ipsec/
    1. Grigoriy
      Grigoriy Гости 30 июля 2017 10:48
      + 0 -
      В вариант описанный в статье по ссылке будет работать для VPN PPTP? и если да, то возможно нужны какие-то корректировки? Извиняюсь за нубский вопрос, только учусь) Сам уже попробовал но не могу понять работает оно или нет, так как сайты открывает все равно с какой-то задержкой.
  6. NoOne
    NoOne Гости 14 июля 2017 01:37
    + 0 -
    Подскажите, сложилась следующая ситуация. Настроил все по инструкции. ВКонтакте и Mail.ru работают нормально, а вот Yandex ни в какую - постоянно перекидывает с yandex.ru на yandex.ua, или с maps.yandex.ru на yandex.ua/maps/, на которых находится заглушка. Как это побороть?
    PS. Использую VPN от zaborona.help
    1. DmitryAVET
      DmitryAVET Создатель 14 июля 2017 08:57
      + +1 -
      Zaborona отдает маршруты клиенту автоматически, советую написать им напрямую. Яндекс в свою очередь пытается самостоятельно обойти блокировки.
      1. NoOne
        NoOne Гости 14 июля 2017 09:42
        + 0 -
        Спасибо за совет. Уже успел разобраться. Как оказалось, это сам Yandex перекидывал с доменов в зоне ru на ua, т.к. у него было прописано в настройках (из-за предыдущих посещений), что я нахожусь в Украине. Изменил в настройках моё расположение на Россию и всё начало работать нормально. Правда карты изначально загружаются в соотвествии с тем, какой город России был мною указан в настройках.
  7. Dmytro
    Dmytro Гости 17 июня 2017 23:00
    + 0 -
    Знизу коменти були про fastrack. В теорії його можна не відключати, якщо в саме правило додати виключення не обробляти пакети що йдуть на потрібні на адреси чи містять певну мітку. Після вихідних буде час перевірю.
    1. DmitryAVET
      DmitryAVET Создатель 17 июня 2017 23:50
      + +1 -
      Так, можна. Для цього треба всі ІР і підмережі згрупувати в один список. Далі в правилі фасттрека на вкладці advanced обрати свій список dst. address list і переконатися, що навпроти нього стоїть знак оклику (тобто для всіх пакетів, крім списку).
  8. Sergey
    Sergey Гости 17 июня 2017 12:38
    + 0 -
    Киевстар умудряется даже влазить в впн тунель подставляя в конце маршрута своих заглушки. Могу скрины показать :)
    Осталось непонятным как брать днс трафик из тунеля. Способ который описывается в конце, не совсем раскрыт что ли? Мы маркируем весь трафик с своей подсети и роутим ВСЕ в тунель. Но если убрать из ip dns адреса днс серверов (8.8.8.8), то имена хостов не резолвятся. При этом коннект к впн серверу идет по ip адресу.
    Зачем прописывать /ip firewall address-list если это нигде не применяется? и как все таки пустить днс через тунель.
    1. DmitryAVET
      DmitryAVET Создатель 17 июня 2017 17:48
      + 0 -
      Да, дейтвительно, в последнем мангле я забыл дописать параметр dst-address-list=dns, чтобы Mikrotik маркировал траффик к ДНС.

      В случае с "Домашний Интернет" от Киевстар, достаточно:

      1) в dhcp-client снять опцию "Use Peer DNS" (отключить использование DNS провайдера)

      2) указать Google DNS 8.8.8.8 / 8.8.4.4 3

      3) после этого очистить кеш DNS:
      /ip dns cache flush


      У КС все реализовано грамотно - IP заблокированы, в случае использовани DNS провайдера, вас переадресовывает на 193.41.60.24 (tequila.i.kyivstar.net).

      КС не перехватывает траффик к чужим DNS (на 53-й порт). т.к. это тянет за собой нарушение законодательства, которое предусматривает блокировку только по решению суда. Google DNS в указе отсутствует, и решения суда на него нет.
  9. gozhdik
    gozhdik Гости 14 июня 2017 16:39
    + 0 -
    Хорошая статья, но можно сделать намного проще, используя всего 1 адрес лист, просто указав вместо ip доменное имя ресурса, тем самым ограничиваясь всего лишь 1 правилом маркировки и 1 статическим маршрутом
    1. DmitryAVET
      DmitryAVET Создатель 14 июня 2017 17:02
      + +1 -
      И да и нет. С обычными саытами - вопросов нет. К примеру VK использует много дополнительных поддоменов, среди которых pp.userapi и *.mail.ru. Отсутствие их в адресных листах приведет к неработоспособности, либо только частичной работоспособности сайта. Многие провайдеры блокируют целые подсети, так что разово введя все подсети - можно надолго забыть о проблеме. Можно вносить и в один адресный лист - кому как удобно.
      1. gozhdik
        gozhdik Гости 14 июня 2017 17:09
        + 0 -
        Тогда уж проще проанализировать те домены которые нужны и добавить их отдельно, ведь список ip сайты периодически могут менять, а может даже на этих айпи существуют и другие ресурсы, на которые траффик гнать через впн нецелесообразно. Лично я себе сделал именно так, добавив этот список:



        И все эти сайты после отключения fasttrack открываются моментально и на первый взгляд все объекты загружаются.
      2. DmitryAVET
        DmitryAVET Создатель 14 июня 2017 22:44
        + 0 -
        По сути, можно добавлять и домены, это уже как вам удобней.
  10. Ан
    Ан Гости 13 июня 2017 17:04
    + 0 -
    zilf,
    А вот это уже вопрос не ко мне) У меня и на старой и на новой с 1400 работает.
  11. zilf
    zilf Посетители 13 июня 2017 16:43
    + 0 -
    ан,
    вк открывается долго и без картинок, mail.ru через раз и то не все сервисы
    1. ан
      ан Гости 13 июня 2017 16:51
      + 0 -
      Очень похоже на mtu. Попробуйте поиграться с 1320 до 1380. У меня такая лажа была с собственным vps. Пока мту 1400 не сделал все медленно открывалось. А если с винды подключится то все нормально было. Опытным путем выяснил что это из-за мту.
      1. zilf
        zilf Посетители 13 июня 2017 16:59
        + 0 -
        Во как - поставил 1380 и поехало и завелось :-) Спасибо.
        А вот теперь проснулся перфекционист внутри - почему на 6.39 все работало с 1400 :-)
  12. Ан
    Ан Гости 13 июня 2017 16:00
    + 0 -
    zilf, Обновитесь до 6.39.2 и поставьте max MTU 1400. Должно заработать имхо
    1. zilf
      zilf Посетители 13 июня 2017 16:21
      + 0 -
      Обновился, поставил 1400 - vk.com очень долго открывается.
      1. ан
        ан Гости 13 июня 2017 16:30
        + 0 -
        Проблема только с вк?
      2. DmitryAVET
        DmitryAVET Создатель 13 июня 2017 16:35
        + 0 -
        VK подгружает часть данных с mail.ru
  13. Антон
    Антон Гости 13 июня 2017 13:50
    + 0 -
    Я правильно понял получается два маскарада? один что б просто в инет ходить, а второе правило для VPN? или весь трафик идет по маскараду где шлюзом VPN?
    1. zilf
      zilf Посетители 13 июня 2017 15:18
      + 0 -
      Правильно поняли. Одно правило nat для общего трафика, второе для трафика только на заблокированные ip через vpn.
      1. Антон
        Антон Гости 13 июня 2017 15:33
        + 0 -
        Большое спасибо
  14. Ан
    Ан Гости 13 июня 2017 10:13
    + 0 -
    zilf,
    Вчера обновился до 6.39.2. впн pptp. все ок. устроиства 951г и 951у
    1. zilf
      zilf Посетители 13 июня 2017 11:34
      + 0 -
      Хм, а чего ж у меня тормозит? На 6.39 норм.
      1. ан
        ан Гости 13 июня 2017 15:19
        + 0 -
        Какой у вас актуал mtu на новой и старой прошивке?
      2. zilf
        zilf Посетители 13 июня 2017 15:43
        + 0 -
        На 6,39
        https://drive.google.com/file/d/0B1HBhB2Z1S2hNDZlZHRJbjRIQ3c

        На 6,39,2 не запомнил.
  15. Ан
    Ан Гости 13 июня 2017 09:54
    + 0 -
    Константин,
    Поставьте принудительно MTU 1400. Должно помочь.
    1. Константин
      Константин Гости 13 июня 2017 12:42
      + 0 -
      Установить MTU 1400 на Mikrotik? Сейчас на Mikrotik MTU 1450, а на сервере 1436.
      1. ан
        ан Гости 13 июня 2017 16:01
        + 0 -
        На клиенте поставьте max MTU 1400. Должно заработать имхо
  16. Константин
    Константин Гости 12 июня 2017 22:03
    + 0 -
    У меня такая ситуация: на работе поднял pptp сервер (со стороны провайдера нету ни каких блокировок), удаленно с Windows, Android удачно подключаюсь к этому серверу и захожу на Yаndex, vk и т.д., а вот с Mikrotik - подключаюсь, но на заблокированные сайты зайти не могу. Когда использую другие vpn серверы на Mikrotik, то все нормально. Не могу понять в чем может быть проблема?
    1. DmitryAVET
      DmitryAVET Создатель 13 июня 2017 08:59
      + 0 -
      Проверьте, включен ли маскарадинг на вашем Mikrotik для ppp. Далее, чтобы заходить, надо либо весь траффик в VPN отправлять (add default route), либо его часть, как в этой публикации.
      1. Константин
        Константин Гости 13 июня 2017 09:24
        + 0 -
        Все настроено в точности, как в этой публикации и работает на разных vpn серверах, которые находил в интернете, но как только подключаюсь к своему PPTP - уже на заблокированные ресурсы попасть НЕ могу... Если же подключаюсь к этому же серверу с Windows, или Android - все работает. Странно как-то...
  17. Stanislaw
    Stanislaw Гости 10 июня 2017 13:21
    + 0 -
    Использую Tools/Email для отправки оповещений о некоторых событиях.
    Провайдер заблокировал smtp яндекса.
    Я сделал всё по Вашей инструкции, заблокированные сайты с устройств в локальной сети открываются.
    Но имейлы с самого микротика не отправляются. Он пытается связаться с smtp напрямую.
    Как его научить отправлять имейлы через vpn?
  18. zilf
    zilf Посетители 8 июня 2017 15:13
    + 0 -
    Что-то поломали Тики в последней прошивке (6.39.2). При настроенном PPTP не проходят пакеты на vk, на mail и yandex со скрипом через раз. Откатился на 6.39 - все нормально. Может автор статьи посмотрит что они там накрутили?
    1. DmitryAVET
      DmitryAVET Создатель 8 июня 2017 15:35
      + 0 -
      Быть может FastTrack включился? Обновился до новой версии, по l2tp+ipsec работает. В ppp были изменения, но не большие.
      1. zilf
        zilf Посетители 8 июня 2017 15:46
        + 0 -
        Да нет, у меня в принципе нету FastTrack (RB850Gx2).
  19. bananagon
    bananagon Посетители 7 июня 2017 09:36
    + 0 -
    Для yandex.ua

    add address=104.17.64.0/20 list=yandex
  20. alexckua
    alexckua Посетители 29 мая 2017 16:06
    + 0 -
    Timophey Pavljuck,
    Аналогичная ситуация с вк - работает через раз. Хотя если vpn с компа, то работает нормально.
  21. Ан
    Ан Гости 28 мая 2017 02:31
    + 0 -
    Расскажите где купили за доллар?
    1. zilf
      zilf Посетители 28 мая 2017 14:31
      + +1 -
      vpn99.net - там как раз есть русский сервер, вот его и выбрал при подключении, уже три дня uptime без разрывов. Только у них не поддерживается p2p.
      1. Ан
        Ан Гости 29 мая 2017 12:36
        + 0 -
        zilf а какие пинги у вас с ya.ru, vk.com?
    2. zilf
      zilf Посетители 29 мая 2017 15:12
      + 0 -
      ya.ru
      Статистика Ping для 87.250.250.242: Минимальное = 30мсек, Максимальное = 31 мсек, Среднее = 30 мсек

      vk.com
      Статистика Ping для 95.213.11.180: Минимальное = 39мсек, Максимальное = 40 мсек, Среднее = 39 мсек
  22. zilf
    zilf Посетители 27 мая 2017 14:32
    + 0 -
    В общем, купил себе канал vpn за 1 доллар в месяц - настроил ip адреса и все хорошо - все летает.
  23. Евгений
    Евгений Гости 24 мая 2017 22:50
    + 0 -
    Может кому пригодится, диапазоны:

    ВКонтакте
    87.240.128.0/18
    93.186.224.0/20
    95.142.192.0/20
    95.213.0.0/18
    185.29.130.0/24
    185.32.248.0/22

    Яндекс
    5.45.192.0/18
    5.255.192.0/18
    37.9.64.0/18
    37.140.128.0/18
    77.75.152.0/22
    77.75.159.0/24
    77.88.0.0/18
    84.201.128.0/18
    87.250.224.0/19
    93.158.128.0/18
    95.108.128.0/17
    100.43.64.0/19
    109.235.160.0/21
    130.193.32.0/19
    141.8.128.0/18
    178.154.128.0/17
    185.32.185.0/24
    185.32.186.0/24
    185.71.76.0/22
    199.21.96.0/22
    199.36.240.0/22
    213.180.192.0/19

    Мейл.ру
    5.61.16.0/21
    5.61.232.0/21
    79.137.157.0/24
    79.137.183.0/24
    94.100.176.0/20
    95.163.32.0/19
    95.163.248.0/21
    128.140.168.0/21
    178.22.88.0/21
    178.237.16.0/20
    185.5.136.0/22
    185.16.148.0/22
    185.16.244.0/22
    188.93.56.0/21
    194.186.63.0/24
    195.211.20.0/22
    195.218.168.0/24
    217.20.144.0/20
    217.69.128.0/20
    178.22.91.0/24
    178.22.92.0/23
    185.16.244.0/23
    195.211.128.0/22
    208.87.94.0/24

    Kaspersky
    77.74.176.0/22
    77.74.181.0/24
    77.74.183.0/24
    93.159.228.0/22
    185.54.220.0/23
    185.85.12.0/24
    185.85.14.0/23
    77.74.176.0/21
    91.103.64.0/21
    93.159.224.0/21
  24. Yurik
    Yurik Гости 24 мая 2017 18:52
    + 0 -
    Где автор брал сии диапазоны?
    Кто автор сего опуса из каши пересекающихся сетей? :)
    вот оптимизированый для ВК, но не уверен, что это настоящие подсети

    87.240.128.0/18
    93.186.224.0/20
    95.142.192.0/20
    95.213.0.0/17
    185.29.130.0/24
    185.32.248.0/22
    
    1. DmitryAVET
      DmitryAVET Создатель 24 мая 2017 19:30
      + 0 -
      Списки предоставлен как есть, без претензий к их точности. Настоятельно рекомендую формировать список самостоятельно, так сказать «под себя». Если есть желание, можете поделиться своими наработками.

      Список подсетей взят с bgp.he.net для VKontakte Ltd (AS47542, AS47541, AS28709). Список точно рабочий, но не отсортирован и не оптимизирован.
  25. Timophey Pavljuck
    Timophey Pavljuck Гости 24 мая 2017 17:43
    + 0 -
    У кого такая же самая проблема, обновите прошивку последней версии. я обновил и о чудо все заработало))
    был в одном шаге от покупки какого нибуть сервака на линуксе. но прошивку обновил и все заработало.

    Правдо с отключенным FastTrack скорость выше 300 мегабит не подымается) с включенным 900-950 ) печаль и тоска)

    вопрос к знатокам. может FastTrack можно включить чисто для основного интерфейса не для впн...
  26. Олег
    Олег Гости 24 мая 2017 10:58
    + 0 -
    на микротике вместо маскарадинга постаил src-nat, все залетало. Может это был косяк моей конфигурации, но при маскарадинге, все соеденения на другом конце туннеля открывались с одного порта.
    1. Тимофей
      Тимофей Гости 24 мая 2017 11:24
      + 0 -
      Можешь подробно написать команду, как ты добавил правила ?
      либо сделать скрины этого правила.
      Буду оч признателен
      1. OLeg
        OLeg Гости 24 мая 2017 13:46
        + 0 -
        NAT Rule

        Action: src-nat
        To Addresses: 10.9.0.2

    2. zilf
      zilf Гости 24 мая 2017 12:25
      + 0 -
      Да, src-nat помогает ускорить процесс, но надо иметь ввиду, что он работает с статическим адресом. Тоесть. при смене адреса, нужно менять вручную, а маскарадинг работает с динамическим адресом. Но всегда рекомендую при работе со статическим адресом использовать именно src-nat, это касается и настроек вообще интернета)

      Скриншот
      1. ottmar
        ottmar Гости 30 мая 2017 23:04
        + 0 -
        А что мешает при подьеме коннекта на событии on-up правило прописывать а при on-down удалять? адрес пира в обработчик передается.
  27. Дмитрий
    Дмитрий Гости 23 мая 2017 12:56
    + 0 -
    Подскажите как быть: сделал все как тут в инструкции, сначала вроде как работало, а потом под вечер перестало, перекидывает на страничку блокировки провайдера. В терминале микротика если пингонуть вк, мейл, одноклассники то пингуется айпишник странички блокировки провайдера. ВПН работает на микротике, пишет что подключен. Если на компе этот же ВПН включить то все странички загружаются.
    1. Дмитрий
      Дмитрий Гости 25 мая 2017 22:01
      + 0 -
      Спасибо за инструкцию с заменой провайдерских ДНС. Все заработало
  28. Robbi
    Robbi Гости 23 мая 2017 02:03
    + 0 -
    Есть сервисы типа https://altvpn.com/ там настроек вообще нет зато прокси есть
  29. DmitryAVET
    DmitryAVET Создатель 23 мая 2017 00:47
    + 0 -
    Важно! На текущий момент RouterOS не поддерживает следующие возможности OpenVPN:
    - UDP режим
    - LZO сжатие
    - TLS аутентификация
    - аутентификация без логина/пароля
  30. Сытник Анатолий
    Сытник Анатолий Гости 22 мая 2017 15:00
    + 0 -
    Давайте делится сервисами vpn. Думаю купить frootvpn.com Только отзывов от украинцев не нашел по скорости. Цена 5$ в мес. Автор этой замечательной статьи каким вы сервисом пользуетесь?
    1. DmitryAVET
      DmitryAVET Создатель 23 мая 2017 11:29
      + 0 -
      Серверов очень много, в том числе бесплатных. Есть даже целые готовые списки таких сервисов, например vpngratis.net. Там же сортировка по типу подключения OpenVPN, PPTP и L2TP. Правда большой скорости и стабильности от таких сервисов не стоит ожидать... бесплатные и народу много.

Mikrotik выпустил обновление RouterOS 6.39.1: попытка исправить ошибки 6.39?

Не успели латвийцы выпустить обновление RouterOS 6.39, как следом за ним уже вышло обновление 6.39.1. В комментариях к предыдущему обновлению на...

Домашняя беспроводная сеть на Mikrotik. Часть вторая: используем возможности

В рамках предыдущей публикации мы рассматривал пример ручной настройки беспроводной сети. Под ручной настройкой подразумевалась индивидуальная...

Построение сети HotSpot на Mikrotik: Часть 2. Настройка CAPsMAN, удаленное

Чуть ранее мы опубликовали инструкцию по созданию и настройке HotSpot на маршрутизаторах Mikrotik под управлением операционной системы RouterOS. В...

Создание и настройка HotSpot на оборудовании Mikrotik под управлением RouterOS

Жизнь современного активного человека немыслима без смартфона и постоянного доступа к сети Интернет. Всё это приводит к необходимости создания...

Киевстар блокирует в Украине сайты по списку Роскомнадзора?

Компания «ВымпелКом» настолько увлеклась блокировкой сайтов в РФ, что поневоле стала блокировать некоторые из них и в Украине, правда не для всех...

Как защитить ребёнка в Интернете?

Интернет напоминает нерегулируемый перекресток с напряженным движением. Сайтов с нежелательным и вредоносным содержимым в Сети огромное количество....


авторизация на сайте

Войти при помощи Вконтакте Войти при помощи Facebook Войти при помощи Google+ Войти при помощи Яндекс
Забыли пароль?