Не работает Simple Queue в RouterOS на оборудовании Mikrotik? Есть решение!

09 июнь 2016 10 626 4

На днях ко мне приехал новенький Mikrotik hAP, предназначенный для установки на одном из филиалов. Установка предполагается в торговой точке, находящейся в фойе заведения с большим потоком людей. Рабочие станции филиала практически не используют емкость выделенного интернет-канала, в связи с чем, было принято решение создать бесплатный «Free Wi-Fi» по инструкции, размещенной чуть ранее.

Уже давно наработанные настройки заработали сразу, а вот Simple Queue работать отказался. Чуть ранее я уже сталкивался с подобной проблемой на hAP lite, тогда я этому значения не придавал.

Суть проблемы в следующем: создано правило Simple Queue, все настройки перепроверены, но правило не ограничивает трафик. Что интересно, при использовании инструмента «Torch» правило начинает срабатывать.

Если Вы хотите научиться настраивать MikroTik, предлагаем пройти онлайн обучение. Более подробную информацию Вы можете найти в конце данной публикации.

Так в чем же причина? Причина в функции «FastTrack», которая включена по-умолчанию в базовой конфигурации на некоторых устройствах. Более подробно о данной функции можно почитать на официальном Wiki на одноименной странице Fasttrack.

Если кратко, функция позволяет ускорить обработку UDP и TCP траффика. Следует понимать, что часть траффика не может проходить «коротким» путем и есть ограничения.

Среди этих ограничений есть и Torch и Simple Queue. При активации Torch, сниффера, системных сканеров, генератора траффика – FastTrack не работает. В то же время при работе FastTrack часть траффика попросту не попадает под действие правил Simple Queue.

Все эти ограничения довольно подробно расписаны в разделе FastTrack, в то же время в документации по Queues этот нюанс упущен.

На официальном форуме Mikrotik присутствует отдельная ветка в которой обсуждается проблема не работающих правил Simple Queue при включенном FastTrack.

FastTrack служит для ускорения обработки траффика, в то время как Queues предназначены для ограничения траффика. Если вам требуется использовать очереди – придется либо дополнительно маркировать пакеты, либо отключать FastTrack.

Самый простой вариант решения проблемы – отключение FastTrack. Делается это в Firewall, отключением соответствующего правила, заметить которое достаточно легко по характерным синим стрелкам.

Просто отключите правило в Firewall и ваши Simple Queue заработают. Такой подход применим в тех случаях, когда маршрутизатор использует незначительное количество системных ресурсов и не приближается к максимальной пропускной способности оборудования. Если же вы используете маршрутизатор, приближаясь к лимитам, использование FastTrack это хороший способ повысить пропускную способность и снизить загрузку процессора.

Видеокурс «Настройка оборудования MikroTik» (аналог MTCNA)

Учитесь работать с MikroTik? Рекомендую видеокурс «Настройка оборудования MikroTik». В курсе разобраны все темы из официальной учебной программы MTCNA и много дополнительного материала. Курс сочетает теоретическую часть и практику – настройку маршрутизатора по техническому заданию. Консультации по заданиям курса ведет его автор Дмитрий Скоромнов. Подойдет и для первого знакомства с оборудованием MikroTik, и для систематизации знаний опытным специалистам.

Интернет-магазин ntools.com.ua

Ключевые слова:

Mikrotik RouterOS RouterBOARD FastTrack Simple Queue

Комментарии:

Добавить
  • bowtiesmilelaughingblushsmileyrelaxedsmirk
    heart_eyeskissing_heartkissing_closed_eyesflushedrelievedsatisfiedgrin
    winkstuck_out_tongue_winking_eyestuck_out_tongue_closed_eyesgrinningkissingstuck_out_tonguesleeping
    worriedfrowninganguishedopen_mouthgrimacingconfusedhushed
    expressionlessunamusedsweat_smilesweatdisappointed_relievedwearypensive
    disappointedconfoundedfearfulcold_sweatperseverecrysob
    joyastonishedscreamtired_faceangryragetriumph
    sleepyyummasksunglassesdizzy_faceimpsmiling_imp
    neutral_faceno_mouthinnocent
  1. Илья
    Илья Гости 29 августа 2019 01:01
    + 0 -
    Спасибо тебе добрый человек, рассказал про FastTrack.
    А то реально сижу мучаюсь, не могу понять почему же simple queues траффик не рубит
  2. Борис
    Борис Гости 18 января 2019 23:51
    + 0 -
    В случае, если есть общий бридж и отдельно гостевой, не проще ли, просто в правилах фасттрека указать - out. interface = общий бридж...
    Мол гости без фасттрека, не гости с фастреком...
    п.с.
    С темой микротика тока начал разбираться, возможно вышеописанное будет осмеяно :)
    1. Гость Alex
      Гость Alex Гости 12 января 2020 15:00
      + 0 -
      Абсолютно верное утверждение, но только при условии, что в фаэрволе прописаны правила для гостевой сети например такие:
      in-interface bridge_guest
      out-interface-list WAN
      И во вкладке: action действие accept

      а после него правило

      in-interface bridge_guest
      И во вкладке: action действие drop

      Где bridge_guest - наша настроенная гостевая сеть
  3. Вареник
    Вареник Гости 9 апреля 2018 02:42
    + 0 -
    На форуме микротика появилось решение.

    До правила с fasttrack:

    /ip firewall filter
    add action=accept chain=forward comment="Guest wifi IP excluded from fasttrack for simple queue processing" connection-state=established,related src-address=192.168.20.0/24
    add action=accept chain=forward comment="Guest wifi IP excluded from fasttrack for simple queue processing" connection-state=established,related dst-address=192.168.20.0/24
    add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related


    где Guest wifi - 192.168.20.0/24

Отключаем навязчивую рекламу в Skype средствами Mikrotik

Надоела навязчивая реклама в Skype? Мне - да. Для владельцев Mikrotik есть удобный трюк, при помощи которого можно отключить рекламу в Skype сразу на...

Домашняя беспроводная сеть на Mikrotik. Часть вторая: используем возможности

В рамках предыдущей публикации мы рассматривал пример ручной настройки беспроводной сети. Под ручной настройкой подразумевалась индивидуальная...

Что будет, когда закончится лицензия Kaspersky Free?

Чуть более года назад я уже писал про бесплатный антивирус от Лаборатории Касперского. С тех пор Kaspersky Free успешно прижились на многих ПК и...

Подключаем 3G-модем к Mikrotik: самый простой вариант резервирования канала. На

Не так давно на одном из небольших филиалов у нас возникли проблемы с интернет-провайдером. Суть проблемы следующая. Есть государственное учреждение,...

Создание и настройка HotSpot на оборудовании Mikrotik под управлением RouterOS

Жизнь современного активного человека немыслима без смартфона и постоянного доступа к сети Интернет. Всё это приводит к необходимости создания...

Guest Wi-Fi: создание гостевой сети Wi-Fi с ограничением скорости на примере

Довольно часто возникают ситуации, когда необходимо предоставить (дома, или же на предприятии) доступ к Интернет через беспроводную сеть сторонним...

авторизация на сайте

Войти при помощи Facebook Войти при помощи Google+
Забыли пароль?