Mikrotik представили обновление RouterOS 6.39: оптимизации, исправления и новые возможности

28 апрель 2017 1 020 5

Были ли у вас проблемы при обновлении на версию RouterOS 6.39?


27 апреля компания Mikrotik представила официальное обновление RouterOS 6.39. Поскольку с момента предыдущего анонса 6.38.5 (9 марта) прошло немало времени, список представленных изменений получился весьма внушительным.

Ранее мы уже рассматривали предварительный список изменений в версии RouterOS 6.39, к финальной версии изменений поднакопилось еще больше. Ниже приведен список некоторых интересных изменений:

  • добавлена поддержка более быстрой разновидности Fastpath, которая будет называться «fast-forward». Соответственно в ROS внесены необходимые параметры. Данная возможность будет использоваться по-умолчанию только для новых бриджей с двумя интерфейсами. Пока только через CLI. для L2TP
  • добавлена поддержка Fastpath при включенном MRRU;
  • для PPP полностью переписан внутренний алгоритм фрагментации (когда используется MRRU), произведена оптимизация под многоядерность;
  • для PPPoE добавлена поддержка Fastpath при использовании MRRU и MLPPP;
  • много доработок и исправлений IPSec и IKE2;
  • расширены возможности клиента TR-069;
  • прекращена поддержка матчера p2p, старые правила больше работать не будут;
  • в QuickSet настройки теперь будет применяться только по нажатию «OK» и «Apply», а не при смене режима как было раньше;
  • для платформы Tile (CCR) исправлены ошибки аппаратного ускорения, благодаря чему значительно улучшена производительность при работе с IPSec;
  • исправления, касающиеся LTE (статус доставки SMS теперь пишется в лог); добавлена поддержка нескольких модемов (D-Link DWR-910, Quectel ec25, Vodafone Huawei R216); улучшена поддержка модема Huawei R216;
  • автоматический перезапуск службы NTP при зависании или ошибке;
  • в QuickSet добавлена начальная поддержка режима «LTE AP» (судя по всему, под новые wAP LTE, LtAP и LtAP mini);
  • для платформы SMIPS уменьшен размер основного пакетаRouterOS, так что владельцы устройств с 16 МБ флеш-памяти теперь смогут нормально скачивать обновление, а не получать ошибку о недостаточном количестве свободного места;
  • в CAPsMAN добавлена поддержка DFS, добавлена возможность указывать несколько каналов в поле Frequency, добавлено фоновое сканирование (background-scan), улучшен алгоритм получения статуса с CAP;
  • для портов Ethernet добавлен параметр voltage-too-low для отображения низкого напряжения (при использовании PoE);
  • устранены ошибки в работе loop-protect на мастер-порту (master-port), раньше могли возникать периодические ложные срабатывания;
  • устранены зависания switch chip, которые приводили к зависанию портов;
  • устранена потеря данных Graphing при отключении питания;
  • для L2TP добавлена поддержка нескольких туннелей L2TP (не путать с несколькими сеансами) между оконечными точками (требуется в некоторых конфигурациях LNS);
  • для сервера L2TP добавлена опция «use-ipsec = required» (требовать использование IPSec);
  • для LED добавлен триггер LTE;
  • в логах добавлен классификатор gps и tr069, записи SNMP сделаны более компактными;
  • для PPP устранены некоторые сбои ядра;
  • SMB: устранены сбои и утечки памяти;
  • для платформы Tile (CCR) и x86 добавлена поддержка твердотельных накопителей NVMe SSD;
  • улучшена производительность беспроводной сети 2.4 ГГц на точках wAP ac;
  • огромное количество исправлений при работе с Winbox;
Обновлено 29.04.2017 21:29 Внимание! В официальной ветке форума по данному обновлению есть пара сообщений о проблемах с обновлениях на платформах RB2011 и RB3011, которые приводят к невозможности загрузки (bootloop). Владельцам данных устройств рекомендуется взвесить все за и против, либо воздержаться от обновления.

Полный список изменений под спойлером.

Ключевые слова:

Mikrotik RouterOS IPSec LTE TR-069 L2TP PPP Tile x86 Winbox

Комментарии:

Добавить
  • bowtiesmilelaughingblushsmileyrelaxedsmirk
    heart_eyeskissing_heartkissing_closed_eyesflushedrelievedsatisfiedgrin
    winkstuck_out_tongue_winking_eyestuck_out_tongue_closed_eyesgrinningkissingstuck_out_tonguesleeping
    worriedfrowninganguishedopen_mouthgrimacingconfusedhushed
    expressionlessunamusedsweat_smilesweatdisappointed_relievedwearypensive
    disappointedconfoundedfearfulcold_sweatperseverecrysob
    joyastonishedscreamtired_faceangryragetriumph
    sleepyyummasksunglassesdizzy_faceimpsmiling_imp
    neutral_faceno_mouthinnocent
  1. Mama
    Mama Гости Вчера, 12:02
    + 0 -
    Господа, метните ссыль на regexp l7 для всего p2p трафика, ибо в 6.39 параметр p2p исчез как класс, а торренты надо отмаркировать.
    Спасибо)
    1. DmitryAVET
      DmitryAVET Создатель Вчера, 13:57
      + 0 -
      На вики микротика есть для торрентов

      /ip firewall layer7-protocol
      add comment="" name=bittorrent regexp="^(\13bittorrent protocol|azver\01\$|get/scrape\\\?info_hash=)|d1:ad2:id20:|\0
      8'7P\\)[RP]"


      /ip firewall mangle
      add action=mark-packet chain=prerouting comment=bittorent_p2p disabled=no in-interface=dsl layer7-protocol=bittorrent new-packet-mark=bittorent_in passthrough=yes
      add action=mark-packet chain=postrouting comment="" disabled=no layer7-protocol=bittorrent new-packet-mark=bittorent_out out-interface=dsl passthrough=yes
  2. DmitryAVET
    DmitryAVET Создатель 8 мая 2017 21:36
    + 0 -
    На офциальном форуме поддержкой дан комментарий по поводу бутлупа (bootloop) на RB3011. Проблема вызвана разделамы, в частности ранее была возможность получить доступ к меню Partitions и создать разделы. В общем, если ранее это было сделано, то в проецссе обновления получается бутлуп.

    Решение: перед обновлением установить количество разделов равное единице (partitions=1):

    /partitions repartition partitions=1


    Для тех, у кого уже бутлуп - можно подключиться при помощи serial, далее в меню RouterBOOT выполнить переразметку (re-partition) на один раздел.
  3. zilf
    zilf Гости 30 апреля 2017 11:48
    + 0 -
    Так же без проблем: SXT Lite2 и RB850Gx2
  4. DmitryAVET
    DmitryAVET Создатель 29 апреля 2017 21:49
    + 0 -
    RB951Ui-2HnD, SXT Lite5, DISC Lite5, hAP и hAP lite - обновление без проблем.

Что нам приготовил Mikrotik в RouterOS 6.39?

В версии ROS 6.39 разработчики приготовили несколько интересных изменений: 1) добавлена поддержка более быстрой разновидности Fastpath, которая...

Mikrotik: обновление загрузчика RouterBOOT в устройствах RouterBOARD, список

RouterBOOT – специальный загрузчик, который отвечает за запуск операционной системы RouterOS на устройствах RouterBOARD компании Mikrotik. На самом...

Подробности новой версии RouterOS v7 от Mikrotik

На официальном форуме компании Mikrotik существует тема, посвященная RouterOS v7.0 beta1, в которой по этому вопросу есть некоторые ответы...

Обновление UniFi Video 3.2.1 и 3.2.2: исправления и оптимизации

Буквально месяц назад компания Ubiquiti представила обновление программного комплекса UniFi Video до версии 3.2.0. Данная версия является своего рода...

Mikrotik выпустил обновление RouterOS 6.34.4 и Winbox v3.4

Компания Mikrotik на этой неделе представила обновление операционной системы RouterOS до версии 6.34.4, а также утилиты Winbox до версии 3.4....

Вышел Mozilla Firefox 16

Mozilla Firefox 16 должен был выйти в массы ещё 9-го октября. Однако уже 10-го октября разработчики Mozilla Foundation обнаружили брешь в...


авторизация на сайте

Войти при помощи Вконтакте Войти при помощи Facebook Войти при помощи Google+ Войти при помощи Яндекс
Забыли пароль?